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Update Purchase Orders 

Update Purchase Orders eliminates the time-consuming steps involved in changing item arrival details, 
vendor cost details, or inventory items for dozens or hundreds of purchase orders in the Sage 300 
Purchase Orders module.  

Update Purchase Orders lets you: 

• Change the expected arrival date of an item or list of items has changed 

• Update the vendor cost for an item or list of items that you enter or import from an Excel file. The 
updated costs come from I/C Vendor Details. 

• Substitute one or more items for other items in multiple purchase orders. 

• Put a range of purchase orders on hold or remove holds from a range of POs. 

• Select ranges of purchase orders for updating by PO number, date, vendor, ship-via code, terms, 
currency, arrival date, locations, PO type, on-hold status, tax group, user, and PO optional fields, 
then load the resulting list of POs to further “cherry-pick” ones for updating.  

Or import a list of the purchase orders that you need to process. 

• Confirm PO details while finalizing the update list. 

• Press a Process button to complete the operation for all selected POs in one step.  

• View a log of all updates after processing. 

Running Update Purchase Orders 

The Update Purchase Orders icon appears under TaiRox Productivity Tools > Purchase Order 
Tools on the Sage 300 desktop and can be copied to other menu locations. 

 

The Update Purchase Orders screen (below) lets you: 

• Update item expected arrival dates, update item vendor costs, substitute one or more items for 
other items, put orders on hold or remove holds for a range of purchase orders that you select by 
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range of PO numbers, purchase order dates, ship-via codes, vendors, terms, expected arrival 
date, locations, PO types, on-hold status, tax groups, users, and/or PO optional fields. 

 

Selecting Purchase Orders for updating 

Choose what to update – expected item arrival date, item vendor cost, items, or 
holds: 

 

• Select “Update Item Expected Arrival Date” or “Update Item Vendor Cost”, then 

o Enter the new Expected Arrival Date – if changing the date. 

o Enter the vendor code for the item – if updating the vendor costs from I/C vebdor details. 

• Select “Substitute Item” to subsitute one or more items on PO with different inventory items. 
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o Click the Drill Down button beside the “List Of Items” field to list the items being substituted. 
o Choose whether to retain the existing line item unit cost for substituted items. 

• Select “Put Purchase Orders On Hold”, then continue to choose the ranges for purchase order 
selection. 

• Select “Take Purchase Orders Off Hold”, then continue to choose the ranges for purchase order 
selection. 

Updating the Item Expected Arrival Date 

 

• Specify the new Expected Arrival Date. The above screenshot shows the arrival date update for a 
specific item. 

• Select “Update Purchase Order Arrival Date Also” to update the Arrival Date for the complete 
purchase order as well. 

Updating the Item Vendor Cost 

The program updates the vendor costs on the PO with the costs stored in I/C Vendor Details. 

 

• The program will update the vendor costs for one or more items from a specific vendor from the 
costs stored in I/C Vendor Details.  

• You must specify a specify item, list of items or all items, as well as the vendor code. 

Substituting Items 

Note:  The program will not substitute items for a completed or partially shipped PO line, or for lines 

that have an Order Entry order number reference. 

Also, we suggest you take care when substituting non-inventory items due to issues with units of 

measure and UOM conversion factors with non-inventory items. We suggest you use the stocking 
units of measure – if both are the same, you will not have an issue. Make sure to check the units of 
measure and extended costs for all substituted items when processing is finished. 
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• Select Substitute Items from the dropdown list. 

• To specify the substitute items list, click the Zoom button beside the dropdown, and add “From” 
items and “To” items to the list in the form that appears. 

o Use the Finder to look up items. Use the Insert key to add new empty lines. 

• Choose whether you want to “Retain Existing Line Item Unit Price.” 

Put Purchase Orders On Hold 

 

• Select “Put Purchase Orders On Hold”, then continue to choose the ranges for PO selection. 

Take Purchase Orders Off Hold 

 

• Select “Take Purchase Orders Off Hold”, then continue to choose the ranges for PO selection. 

Choose a single item, list of items, or all items: 

If updating the expected arrival date or the vendor cost, you can specify a single item, all items, or a 

list of items. If you select “Substitute Items, you must use the item list to specify a single item or list of 
items. 

• If you choose a list of items, the list will be remembered from the previous time you used it to load 
POs for updating.  

• To create/edit an item list. click on the Drill Down icon on the right side of the dropdown field. 

The list will be remembered from the previous Load. 

 

To insert items: 

o Use the Insert key to add more items to the list. 

o Use the Delete key to remove items. 
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o The list will be remembered from the previous time you used it to update purchase orders.  
o Click the Reset Defaults button to delete all items from the list. 

To import a list of items or item substitutions: 

o Click the Import button at the bottom of the popup form and select the spreadsheet containing 
the item list. 
− The imported list will replace the current list of items. 

o Use the Insert key to add more rows to the list. 
o Use the Delete key to remove items from the imported list. 
o Click the Reset Defaults button to delete all items from the list. 

Import format: 

You can find sample import files in directory \Sage300\XL61A\Documentation. 

Note:  The Excel Spreadsheet for an item list (Items.xlsx) is a single column with “ITEMNO” as 
the column heading in the first row.  

 

Choosing Ranges of Purchase Orders 

 

• You can specify ranges of purchase orders – for example, to restrict POs by PO number, date, 
vendor, ship-via code, terms, currency, arrival date, locations, PO type, on-hold status, tax group, 
user, or optional PO fields (if added). 

Or you can import a list of the purchase orders that you need to process. 

For details on importing a list of POs, see Importing a List of Purchase Orders for Processing. 

• You can add or remove fields from the dropdown list using the Field Settings button. 

Use the “Field Settings” button to customize the list of fields for selecting POs: 

Click the Field Settings button to change the fields that appear in the “Select Purchase Orders By” 

dropdown list.  
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• The list of fields on the right are the fields that will appear in the Select Purchase Orders By 
dropdown.  

• To add a field to the dropdown list, select it in the list on the left, and click the Include button. 

Note regarding PO dates:  

• If you choose a range of Purchase Order Dates, the default “To” date is set by a screen accessed 
through the Update Purchase Orders > File > Settings menu choice: 

 

You can override the default in the Range fields. 

Choose additional criteria if necessary: 

To select purchase orders with a field that is NOT available on the Field Settings form, use Additional 

Criteria. 

 

• Click the Additional Criteria button to further restrict the POs retrieved for the update.  

• Select a field in the dropdown and click the Add button. 

• Double-click the Criteria field to enter a relationship and value. 

• Click OK to save. 
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Load the list of selected POs and choose which ones to update: 

 

• Click the Load button to display the selected list of purchase orders. 

o Go back and adjust the ranges or additional criteria if necessary. 

• Use the Select All and Select None buttons. 

• Click the Purchase Order Number column heading to drill down on the selected receipt: 

 

• Double-click in the Include column to “cherry-pick” from the PO selections: 

 

You can also delete a PO by selecting it and pressing the Delete key: 

• You can also delete a purchase order from the Purchase Orders program by selecting the row in 
the Load list and pressing the Delete key. When the delete key is pressed you will be prompted 
to confirm the deletion of that purchase order. 

Importing a List of Purchase Orders for Processing 

You can import a list of the purchase orders that you need to process – or you can select purchase 

orders by providing PO ranges and specifying additional criterial. 

Note that you must specify what you are updating in the “Update Purchase Order” section 
at the top of the form before you import the order list. 

For details on specifying and loading ranges of purchase orders, see Choosing ranges of purchase 

orders. 

To import a list of orders for updating: 

• Choose File > Import from the Update Purchase Orders menu. 



Update Purchase Orders  Selecting Purchase Orders for updating 

TaiRox Productivity Tools for Sage 300  8 

© 2009-2024 TaiRox Software Inc. All rights reserved.  

 

• Select the list of POs that you want to process. 

 

• The program will import the list and load all relevant purchase orders into the grid – setting all 
POs to “Include” – and display a message stating the number of purchase orders that were 
successfully loaded, and the number of purchase orders that could not be imported. 

 

The program will reject purchase orders that cannot be processed. 

For example 

o If you specified a list of items for updating the expected arrival date, the program will reject 
orders that do not include the items you specified. 

o The program will reject completed purchase orders. 

• You can double-click the “Include” column to remove purchase orders from the update. 

Click the Process button to update the included purchase orders: 

The program asks you to confirm your choices. Click Yes to continue. 

 

Note: 

• When updating Item Vendor Cost, no action will be taken if there is no Item Vendor Cost 
or if the cost is zero. 
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Click the Log button to confirm which purchase orders were deleted: 

6/25/2020 3:47:26 PM Update Purchase Orders started. 

6/25/2020 3:47:26 PM  

6/25/2020 3:47:26 PM Performed by user: ADMIN 

6/25/2020 3:47:26 PM  

6/25/2020 3:47:26 PM Update Item Expected Arrival Date 

6/25/2020 3:47:26 PM All Items 

6/25/2020 3:47:26 PM Expected Arrival Date [7/10/2020] 

6/25/2020 3:47:26 PM Update Purchase Order Arrival Date Also [No] 

6/25/2020 3:47:26 PM  

6/25/2020 3:47:26 PM Purchase Order Range 

6/25/2020 3:47:26 PM     Purchase Order Number From [] To [ZZZZZZZZZZZZZZZZZZZZZZ] 

6/25/2020 3:47:26 PM  

6/25/20 3:47:26 PM Updating expected arrival dates for Purchase Order Number PO000000025... 

6/25/2020 3:47:26 PM     Purchase Order Number PO000000025 updated. 

6/25/2020 3:47:26 PM  

6/25/2020 3:47:26 PM Update Purchase Orders complete. 

6/25/2020 3:47:26 PM 

================================================================================ 

The Log lists: 

• The user and the range settings. 

• Each purchase order that was updated.  
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File Formats for Imported Purchase Order and Item Lists 

Update Purchase Orders has several functions that let you update groups of POs using an imported PO 

list and an imported list of item numbers. 

Import files – purchase orders and item lists – are Excel files.  

You can find examples of import lists in directory “…\Sage300\XL61A\Documentation”. 

Purchase Order List 

Instead of specifying a range of purchase orders and clicking the Load button, you can directly import a 

list of POs. 

The Excel Spreadsheet order list is a single column with “PONUMBER” as the column heading in the first 

row.  

 

• All other columns are ignored. This means that you can add descriptions and notes to your 
spreadsheet without affecting the file import. 

Item Lists 

The Excel Spreadsheet item list is a single column with “ITEMNO” as the column heading in the first row.  

 

Notes: 

• Item numbers can be formatted or unformatted. 

• All other columns are ignored. This means that you can add item descriptions and notes to your 
spreadsheet without affecting the file import. 
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