
Delete Items Running Delete Items 

TaiRox Productivity Tools for Sage 300  1 

© 2009-2024 TaiRox Software Inc. All rights reserved.  

Delete Items 

Sage 300 allows inventory items to be deleted as long as there are no quantities in stock – however, this 

can be a problem.  

• Even when item quantities are zero, item numbers can still appear in orders or purchase orders 
or historical data that has yet to be purged.  

• If an item is deleted when it is still referenced in other modules, the integrity checking program will 
flag these references as errors, and some operations in Sage 300 may not behave as expected. 
In addition, some reports will display incomplete or inaccurate data. 

TaiRox Delete Items lets you safely delete items from Inventory Control.  

When you use TaiRox Delete Items, it looks through all core Sage 300 tables and known third-party 
tables searching for references to all items matching your selection criteria, then displays a filtered list for 
which there are no references. 

The program also lists all unknown third-party applications that may or may not reference items. Subject 

to the Important Disclaimer below, these items are "safe to delete" and can be deleted using the Delete 
Items user interface.  

Important Disclaimer:  Delete Items is driven by XML files that identify Sage 300 and third-party 
products with the tables and columns of the products that contain inventory items.  

TaiRox does not guarantee that these XML files are accurate, complete or up-to-date, and that all 

references will be detected by Delete Item's search.  

If other users are using Sage 300 when Delete Items is being run, the results of the search may be 

out-of-date as displayed. TaiRox is not responsible for any damaged or lost data as a result of using 
Delete Items. A Sage 300 Certified Consultant should be involved in any extensive deletion process 
so that integrity checks and other tests can be performed after deletion. 

Nevertheless:  Sage 300 business objects are used to delete items, so the resulting database will 

have at least as much integrity as if a Sage 300 UI was used to delete items. If an item has 
references undetected by Delete Items, in many cases data can be repaired by simply adding the 
item back to the database.  

Delete Items creates a log of all items that it deletes. 

A listing of the XML applications file that drives Delete Items is provided at the end of this document. 

Delete Items lets you: 

• Select ranges of items by item number, item category, or account set – or any of the optional 
fields used for item records (as shown in the dropdown above). You can select ranges using up to 
seven fields – or you can import a list of the items that you want to delete. 

TaiRox Delete Items selects Inventory Control items with the same mechanisms used by core 

modules when printing reports. 

• Specify additional criteria using item fields. 

• Load the list of items that are “safe to delete” from the range of items that you specified. 

(When you click the Load button, the program displays items that are referenced ONLY in the 
ICITEM tables.) 
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• “Cherry-pick” items for deletion from the “safe-to-delete” list of items.  

• Optionally Delete Items individually by selecting them from the loaded list of “safe-to-delete” items 
and pressing the Delete key. 

• Press a Process button to complete the operation for all selected items in one step.  

• View a log of all deletions after processing. 

Running Delete Items 

The Delete Items icon appears under TaiRox Productivity Tools > Inventory Control Tools on 

the Sage 300 desktop and can be copied to other menu locations. 

  

The Delete Items screen (below) lets you select which items you wish to delete by specifying a range of 

item numbers, item categories, item account set codes, and any optional fields that you use for items. 
You can use up to seven fields to specify ranges. 
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Selecting Items for deletion 

Timing Notes:  In a database with tens of thousands of items, the search may take several seconds 
or minutes.  

For very large databases, TaiRox recommends filtering for a portion of the items to get a sense of 

how long the process will take. In order to minimize the time, the tables are searched in a particular 
order. Once an item has been detected in a table, other tables are not searched for that item. 

Choose ranges of items: 

 

• You can specify ranges of items to restrict them by item number, item category, or account set – 
or any of the optional fields used for item records (as shown in the dropdown above). You can 
select ranges using up to seven fields. 

For instructions on importing a list of items for deletion using the File > Import menu choice, see 
Importing a List of Items for Deletion. 

Choose additional criteria: 

 

• Click Additional Criteria to further restrict the items retrieved for deletion. In this case, we are only 
going to load inactive items. 

• Click OK to save. 

Load the list of selected items and choose which ones to delete: 

• Click the Load button to display the selected list of items. 
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o Go back and adjust the ranges or additional criteria if necessary. 

Importing a List of Items for Deletion 

• Choose File > Import from the Delete Items menu. 

 

• Select the list of items that you want to process. 

 

• The program will import the list and load all relevant items into the grid – setting all items to 
“Include” – and display a message stating the number of items that were successfully loaded, and 
the number of items that could not be imported. 

 

The program will reject items that cannot be processed, and will not import them. 

For example, the program will not allow an item to be deleted if there are any quantities in stock 

(as in the above screen,, where one item was rejected). 

All items that can be deleted will be loaded into the grid at the botton of the screen. You can then 

confirm which items you want to delete. 

Choosing Items from the Grid for Processing 

• Use the Select All and Select None buttons below the grid to set all items to Yes for Include or No 
to exclude. 

 

• Double-click in the Include column to “cherry-pick” from the items: 
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• Click the Item Number column heading to drill down on the selected item to confirm the details: 

 

You can also delete an item by selecting it and pressing the Delete key: 

• You can also delete an item from inventory by selecting the row in the Load list and pressing the 
Delete key. When the delete key is pressed you will be prompted to confirm the deletion of that 
item. 

 

Click the Process button to delete the included items: 

The program asks you to confirm your choices.  

In this case, it also asks you to confirm that the third-party program in the message does not affect 

Inventory items, and it is safe to proceed. 

• Click Yes to continue. 

 

Note:  There can also be data-integrity errors that prevent some deletions, in which case an error 
message will appear. 

Click the Log button to confirm which items were deleted: 

7/27/2020 12:45:01 PM Delete Items started. 

7/27/2020 12:45:01 PM  

7/27/2020 12:45:01 PM Performed by user: ADMIN 

7/27/2020 12:45:01 PM  

7/27/2020 12:45:01 PM Item Range 

7/27/2020 12:45:01 PM     Item Number From [] To [ZZZZZZZZZZZZZZZZZ] 

7/27/2020 12:45:01 PM  

7/27/2020 12:45:01 PM Deleting Item Number C2-999/G... 

7/27/2020 12:45:01 PM     Item Number C2-999/G deleted. 

7/27/2020 12:45:01 PM  

7/27/2020 12:45:01 PM Delete Items complete. 

7/27/2020 12:45:01 PM 

================================================================================ 
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The Log lists: 

• The user and the range settings for the procedure. 

• Each item that was deleted.  

Delete Items XML Control File – Applications.xml 

The following XML file is used to control application checking for item references. 

<?xml version="1.0" encoding="utf-8"?> 

<Applications xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 

xmlns:xsd="http://www.w3.org/2001/XMLSchema"> 

   <Application> 

      <Selector>AM</Selector> 

      <Name>Norming Asset Management</Name> 

      <Check>true</Check> 

   </Application>    

   <Application> 

      <Selector>AP</Selector> 

      <Name>Accounts Payable</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>AR</Selector> 

      <Name>Accounts Receivable</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>AS</Selector> 

      <Name>Administrative Services</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>AU</Selector> 

      <Name>Audit Logger</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>BF</Selector> 

      <Name>Sage 300 Intelligence Report Manager</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>BJ</Selector> 

      <Name>Sage 300 Intelligence Connector</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>BH</Selector> 

      <Name>Sage 300 Intelligence Analysis</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>BK</Selector> 

      <Name>Bank Services</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>BV</Selector> 

      <Name>Sage 300 Intelligence Report Viewer</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>BY</Selector> 

      <Name>Sage 300 Intelligence Report Designer</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>CP</Selector> 
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      <Name>Canadian Payroll</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>CS</Selector> 

      <Name>Common Services</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>CT</Selector> 

      <Name>Cdn Payroll Tax Update</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>EB</Selector> 

      <Name>Orchid Enhanced Budgeting</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>EL</Selector> 

      <Name>EFT Processing</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>EW</Selector> 

      <Name>Sage CRM Integration</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>GL</Selector> 

      <Name>General Ledger</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>GP</Selector> 

      <Name>G/L Subledger Services</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>IC</Selector> 

      <Name>Inventory Control</Name> 

      <Check>true</Check> 

   </Application> 

   <Application> 

      <Selector>IY</Selector> 

      <Name>Inter Entity Transactions</Name> 

      <Check>true</Check> 

   </Application> 

   <Application> 

      <Selector>OE</Selector> 

      <Name>Inventory Control</Name> 

      <Check>true</Check> 

   </Application> 

   <Application> 

      <Selector>OZ</Selector> 

      <Name>Process Scheduler</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>OY</Selector> 

      <Name>Orchid Bin Tracking</Name> 

      <Check>true</Check> 

   </Application> 

   <Application> 

      <Selector>PM</Selector> 

      <Name>Project and Job Costing</Name> 

      <Check>true</Check> 

   </Application> 

   <Application> 

      <Selector>PO</Selector> 

      <Name>Purchase Items</Name> 

      <Check>true</Check> 

   </Application> 
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   <Application> 

      <Selector>RA</Selector> 

      <Name>Return Material Authorizations</Name> 

      <Check>true</Check> 

   </Application> 

   <Application> 

      <Selector>SA</Selector> 

      <Name>Sales Analysis</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>SG</Selector> 

      <Name>Accounts Code Change</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>SI</Selector> 

      <Name>Item Number Change</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>SP</Selector> 

      <Name>Vendor Number Change</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>SR</Selector> 

      <Name>Customer Number Change</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>TX</Selector> 

      <Name>Tax Services</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>UP</Selector> 

      <Name>US Payroll</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>UQ</Selector> 

      <Name>Ops Inquiry</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>UT</Selector> 

      <Name>US PR Tax Update</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>VM</Selector> 

      <Name>Technisoft Service Manager</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>WW</Selector> 

      <Name>TaiRox Check Approval</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>XA</Selector> 

      <Name>App Manager</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>XO</Selector> 

      <Name>TaiRox Extended Processing</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>XK</Selector> 

      <Name>SOX Second Sight</Name> 
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      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>XL</Selector> 

      <Name>TaiRox Productivity Tools</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>XX</Selector> 

      <Name>Software Development Kit</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>ZC</Selector> 

      <Name>G/L Consolidations</Name> 

      <Check>false</Check> 

   </Application> 

   <Application> 

      <Selector>ZI</Selector> 

      <Name>Inter Company Transactions</Name> 

      <Check>false</Check> 

   </Application> 

</Applications> 
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File Formats for Imported Item Lists 

Delete Items lets you select items using an imported item list. 

Import files are Excel files.  

You can find examples of import lists in directory “…\Sage300\XL61A\Documentation”. 

Item Lists 

The Excel Spreadsheet item list is a single column with “ITEMNO” as the column heading in the first row.  

 

Notes: 

• Item numbers can be formatted or unformatted. 

• All other columns are ignored. This means that you can add item descriptions and notes to your 
spreadsheet without affecting the file import. 
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